Developping Expired Ektachrome P800/1600

Film Photography & Darkroom discussion

Moderator: Keith Tapscott.

Post Reply
oliver.compton
Posts: 1
Joined: Sat Apr 04, 2020 11:01 am

Developping Expired Ektachrome P800/1600

Post by oliver.compton »

I just shot a 25 year old roll of expired Kodak Ektachrome P800/1600 film (reversal). I've shot a bit of expired film but never slide film and I'm just curious how I should get it developed.
Knowing that it would be less sensitive (it was not stored in a cool place), I decided to shoot at a lower ISO. The roll has 4 options and says to circle which speed you used: 400 - E-6, 800 - P1, 1600 - P2 and 3200 - P3. I stupidly didn't pay attention to that when I put it in and thought it was 200 for some reason, so I shot it at 100 ISO.
My question is, if I got it developed like it is 400, would my compensation for the degraded sensitivity be adequate or too much? In other words, should I get it developed at 400 or pull it to 200?? I'm still figuring out expired film and push/pull techniques, so excuse me if that was confusing. Would appreciate any insight or suggestions into what to do. Thanks!!

pentaxpete
Posts: 95
Joined: Thu Jan 12, 2006 7:19 am
Location: BRENTWOOD,Essex,(UK)

Re: Developping Expired Ektachrome P800/1600

Post by pentaxpete »

I was GIVEN a load of Fuji RMS film which could be up-rated from 100ASA -- it is dated 2002 and I have kept it cold in freezer for years . I rate it 64 ASA -- do not 'Push' as it is not 'Fresh' any more and have it processed 'NORMAL ' and it comes out great. What happens with Slide E6 fiml is that over the years 'Fog Level ' reduces the 'D-Max' ( Black Density) so if you 'Push ' by developing longer in First Developer you loose MORE D-max as there is not enough silver left for the Colour Developer to form a good 'black' .
Got COMPUTERISED and 'slightly Digitised Pentax K10D' but FILM STILL RULES !

Post Reply